Performance issues in Jira
Incident Report for Jira Work Management
Resolved
Between 12:00 March 7th and 12-25 March 7th UTC, we faced performance problems with the Jira Issue View for some EU customers. The issue has been resolved and the service is operating normally.

We are closing this incident for now.
Posted Mar 07, 2024 - 14:24 UTC
Investigating
We have identified ongoing performance problems with the Jira Issue View for some EU customers. We are actively working to resolve this issue as quickly as possible.
Posted Mar 07, 2024 - 13:14 UTC
This incident affected: Viewing content, Create and edit, Search, Administration, and Automation for Jira.