Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health to receive notifications if a reliability incident affects your organization.
The issue causing Jira users inability to log time on business board has been resolved. A fix was deployed to address the problem and the service is operating normally for all affected customers.
Posted May 06, 2026 - 06:39 UTC
Identified
Our engineering teams have identified the cause and are in process of deploying a fix. We will share further updates in next 3 hours, or sooner if we have any meaningful developments to report.
Posted May 06, 2026 - 04:16 UTC
Investigating
We are investigating reports of users unable to log time while on business board. Our engineering teams are actively investigating and working to resolve the issue. We will provide more updates in next 1 hour.