Wide ranging performance regression
Incident Report for Jira Work Management
Resolved
Between 15 Feb 23 2:37 AM UTC and 16 Mar 23 4:00 AM UTC, all customers experienced an average extra latency of 100 milliseconds on all API requests for Jira Work Management, Jira Service Management, and Jira Software. The root cause was the addition of circuit breaker functionality to our caching infrastructure that caused increased CPU utilisation in all paths. We have deployed a fix to mitigate the issue and have verified that the services have recovered. The conditions that cause the bug have been addressed and we're actively working on a permanent fix. The issue has been resolved and the service is operating normally.
Posted Mar 21, 2023 - 00:01 UTC
Monitoring
We have identified the root cause of the performance regression and have mitigated the problem. The fix is being rolled out globally and we are now monitoring closely to make sure it has resolved the issue.
Posted Mar 16, 2023 - 03:38 UTC
Identified
We continue to work on resolving the performance regression for Jira Work Management, Jira Service Management, and Jira Software. We have identified the root cause and expect recovery shortly.
Posted Mar 16, 2023 - 01:32 UTC
Investigating
We are investigating cases of degraded performance for all Jira Work Management, Jira Service Management, and Jira Software Cloud customers. It appears there is a regression of of about 100 milliseconds on many user experiences. We are investigating this and will update in the next hour.
Posted Mar 16, 2023 - 00:45 UTC
This incident affected: Viewing content and Create and edit.